APM2.8 with internal compass

1.Note, If you want to use build-in compass , should insert the jumper,

If you want to use external compass , should remove the jumper

Can not use build-in and external compass at the same time.

If want to use external compass,

2.Use mission planner to calibrate apm. Do not recommend to use apm planner ground station. Do not recommend to use the latest version Mission Planner, because the latest version cannot be used to upload firmware online for apm, now it is used for pixhawk flight controller.

For example, use 1.3.62 or older, download mission planner from here, http://firmware.ap.ardupilot.org/Tools/MissionPlanner/archive/MissionPlanner-1.3.62.msi

You can see all the version here, http://firmware.ap.ardupilot.org/Tools/MissionPlanner/archive

3. Do not upload latest firmware offline to apm board.

Due to the limited memory space of the APM board, the latest firmware cannot be uploaded. If you use the mission planner to flash online, it will automatically help you to upload the firmware suitable for the APM board.For example, the copter firmware for apm is 3.2.1 (mission planner will help you upload this version),the latest version is for PIXHAWK , if you upload offline above 3.2.1, it will clear the bootloader of chip, then you cannot use apm.

So, upload firmware online at mission planner, if you upload offline, make sure the version is not above 3.2.1(copter, for example)

One thought on “APM2.8 with internal compass

  • July 16, 2021 at 5:04 am
    Permalink

    I appreciate, cause I found exactly what I was looking for. You’ve ended my four day long hunt! God Bless you man. Have a great day. Bye

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *